Debian ClamAV Upgrade – clamd LibClamAV Error: Can't load /var/lib/clamav/daily.cld: Malformed database

Fehler:
clamd LibClamAV Error: Can’t load /var/lib/clamav/daily.cld: Malformed database
 
Lösung:
Zuerste prüfen ob alle Paket von ClamAV auf dem gleichen Stand sind.
apt-get update && apt-get upgrade
bzw.
dpkg -l | grep clam
Falls nicht nachinstallieren und folgende Schritte ausführen, falls der Fehler durch das Upgrade noch nicht verschwunden ist.

  1. Alle Dateien unter /var/lib/clamav/ löschen
  2. freshclam ausführen
  3. /etc/init.d/clamav-daemon start

Beim freshclam kann es passieren, dass er sich einen überlasteten Server aussucht. Da kann ein Abbruch und Neustart helfen.